バージョン2.6/2.7向けのPythonモジュール

私は私のUbuntuシステムで2つのPythonバージョンを使用する必要があります:2.6.5と2.7.2(いくつかのサードパーティのプロジェクトとの互換性のため)。

どちらもPyGTKパッケージが必要です。

私はこのパッケージの最新バージョンをインストールしましたが、不思議なことに、2.6バージョンだけがそれを識別します。
2.7バージョンはそれを見つけることができません:

[email protected]:/usr/lib$ python2.6 
Python 2.6.5 (r265:79063, Apr 16 2010, 13:57:41) 
[GCC 4.4.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import pygtk
>>> print pygtk._get_available_versions()
{'2.0': '/usr/lib/gtk-2.0'}
>>> quit()

[email protected]:/usr/lib$ python
Python 2.7.2 (default, Aug 16 2011, 09:51:01) 
[GCC 4.4.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import pygtk
Traceback (most recent call last):
  File "", line 1, in 
ImportError: No module named pygtk
>>> 

ベストアンサー

両方のバージョンでpyGTKを個別にダウンロードしてインストールする必要があるかもしれません。
OSパッケージインストーラは使用しないでください。

両方のバージョンのPyGTKの別々の卵パッケージをダウンロードしてください。それぞれのPythonインタプリタを使って各eggのsetup.pyを実行します。例えば。

`…../python26/python /download/pyGTK-2.6/setup.py install

…../python27/python /download/pyGTK-2.7/setup.pt install`

コメントする

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です